webpack执行压缩报错 ERROR in js/bundle.js from UglifyJs

@ckinmind 2017-01-08 08:03:00发表于 ckinmind/ReactCollect webpack

参考资料:stackoverflow: Webpack error ERROR in bundle.js from UglifyJs

问题引起的原因可能是我在main.js中定义的变量用的是let, 而在webpack中配置的打包的使用webpack的plugin, 要压缩ES6代码需要用babel-plugin-uglify,所以解决方案是要么将ES6中let定义变量改为var定义,要么用babel-plugin-uglify去压缩代码